The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

yum update returns error "Multilib version problems found."

Discussion in 'General Discussion' started by postcd, Sep 20, 2015.

  1. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    621
    Likes Received:
    6
    Trophy Points:
    18
    Hello, after i executed "yum update" on my WHM server, it started working and then stopped with following lines at the end:

    Code:
    --> Finished Dependency Resolution
    --> Running transaction check
    ---> Package kernel-devel.x86_64 0:2.6.32-504.8.1.el6 will be erased
    --> Finished Dependency Resolution
    Error:  Multilib version problems found. This often means that the root
           cause is something else and multilib version checking is just
           pointing out that there is a problem. Eg.:
    
             1. You have an upgrade for libffi which is missing some
                dependency that another package requires. Yum is trying to
                solve this by installing an older version of libffi of the
                different architecture. If you exclude the bad architecture
                yum will tell you what the root cause is (which package
                requires what). You can try redoing the upgrade with
                --exclude libffi.otherarch ... this should give you an error
                message showing the root cause of the problem.
    
             2. You have multiple architectures of libffi installed, but
                yum can only see an upgrade for one of those arcitectures.
                If you don't want/need both architectures anymore then you
                can remove the one with the missing update and everything
                will work.
    
             3. You have duplicate versions of libffi installed already.
                You can use "yum check" to get yum show these errors.
    
           ...you can also use --setopt=protected_multilib=false to remove
           this checking, however this is almost never the correct thing to
           do as something else is very likely to go wrong (often causing
           much more problems).
    
           Protected multilib versions: libffi-3.0.5-3.2.el6.i686 != libffi-3.0.9-1.el5.rf.x86_64
    can i fix this anyhow? can this break WHM updating functions?
     
  2. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    621
    Likes Received:
    6
    Trophy Points:
    18
    Thanks, i checked that thread, but im not able to solve it.

    the "yum update" error is:
    Protected multilib versions: libffi-3.0.5-3.2.el6.i686 != libffi-3.0.9-1.el5.rf.x86_64

    My CentOS is 6.6, x86_64 . Does it mean i have CentOS 5 package installed and that is issue?

    # rpm -qa | grep libffi
    libffi-3.0.9-1.el5.rf.x86_64

    # yum list libffi
    Installed Packages
    libffi.x86_64 3.0.9-1.el5.rf @rpmforge
    Available Packages
    libffi.i686 3.0.5-3.2.el6 base

    # yum repolist enabled
    base CentOS-6 - Base 6513+62
    draios Draios 11
    *epel Extra Packages for Enterprise Linux 6 - x86_64 11069+695
    extras CentOS-6 - Extras 43
    updates CentOS-6 - Updates 379+48
    vz-base vz-base 3
    vz-updates vz-updates

    how can i please install/reinstall it good so yum update works?

    i found nothing suspicious in /etc/yum.repos.d

    someone adviced:
    #rpm -e --nodeps libffi

    but not sure if its safe
     
    #3 postcd, Sep 24, 2015
    Last edited: Sep 24, 2015
  3. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    621
    Likes Received:
    6
    Trophy Points:
    18
    I tried that command:
    #rpm -e --nodeps libffi
    then this one:
    #yum install libffi-devel

    and it worked to install el6 version

    # yum update
    than was not interupted and wanting me to upgrade 187 packages and install 13
    here: http://pastebin.com/ZViBywTa

    please can anyone advice is i should proceed with such update safelly?

    PS: might be good if WHM notiffy me there is an issue with updating of server software
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You may want to consider removing the RPMForge YUM repo if you are not using it for a specific purpose. It's not utilized by default and it's possible that it's the source of this error message. Otherwise, you can proceed with updating the packages as advised in the output of the "yum update" command.

    Thank you.
     
Loading...

Share This Page