Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Yum upgrade error - libmysqlclient missing on server?

Discussion in 'General Discussion' started by Galanthus, Apr 16, 2014.

  1. Galanthus

    Galanthus Well-Known Member

    Joined:
    Nov 8, 2013
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hi Guys,

    I need some help here i have tried to upgrade YUM to the lastest version. There is a total of 58 packages which has to be updated. When i start with: yum upgrade i get this error libmysqlclient_r.so.16()(64 bit) is needed by mysql client.

    Please take a look at my screenshot.

    BTW: The libmysqlclient is on my server.. how can i fix this issue?

    Schermafbeelding 2014-04-16 om 09.37.29.png
     
    #1 Galanthus, Apr 16, 2014
    Last edited: Apr 16, 2014
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    834
    Likes Received:
    28
    Trophy Points:
    178
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,749
    Likes Received:
    1,886
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Could you post the output from "yum update" in "code" tags instead of as a screenshot? This will help us to troubleshoot the error messages. Also, are you using Cloud Linux, or have you installed any custom MySQL packages?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Galanthus

    Galanthus Well-Known Member

    Joined:
    Nov 8, 2013
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello i am only allowed to use a web based SSH client. But i am only seeing the same thing. That libmysqlclient_r.so 16()(64 bits) is needed.

    However i tried to locate this file it does exist but i am not able to upgrade YUM.

    See screenshot.

    Schermafbeelding 2014-04-18 om 11.23.14.png
     
  5. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,749
    Likes Received:
    1,886
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice