endfm

Registered
Sep 19, 2018
3
1
3
Aust
cPanel Access Level
Root Administrator
Hello cPanel,

I hope this is the right area to post if not can a mod move this into the appropriate forum, I'm having a bit of an issue, updating within whm and also from console using
Code:
sudo yum update[code]

I am running, 

[LIST][*]CENTOS 6.10 xen pv [ns1][/LIST]
 
[LIST][*]v78.0.18[/LIST]
 
[LIST][*]Load Averages: 0.61 0.34 0.18[/LIST]


Once the above code has been updated WHM & cPanel spits out this below, 

[code]Command line error: no such option: -b
[email protected] [~]# sudo yum update --skip-broken
Loaded plugins: fastestmirror, universal-hooks
Setting up Update Process
Loading mirror speeds from cached hostfile
 * EA4: 27.50.85.8
 * cpanel-addons-production-feed: 27.50.85.8
 * cpanel-plugins: 27.50.85.8
 * base: mirror.ventraip.net.au
 * epel: fedora.melbourneitmirror.net
 * extras: mirror.ventraip.net.au
 * updates: mirror.optus.net
Resolving Dependencies
--> Running transaction check
---> Package wp-cli.noarch 0:1.5.1-2.2.2.cpanel will be updated
---> Package wp-cli.noarch 0:2.1.0-1.el6 will be an update
--> Processing Dependency: php for package: wp-cli-2.1.0-1.el6.noarch
--> Processing Dependency: php-cli for package: wp-cli-2.1.0-1.el6.noarch
--> Processing Dependency: php-common for package: wp-cli-2.1.0-1.el6.noarch
--> Processing Dependency: php-json for package: wp-cli-2.1.0-1.el6.noarch

Packages skipped because of dependency problems:
    wp-cli-2.1.0-1.el6.noarch from epel
and

Code:
[email protected] [~]# sudo yum update
Loaded plugins: fastestmirror, universal-hooks
Setting up Update Process
Loading mirror speeds from cached hostfile
 * EA4: 27.50.85.8
 * cpanel-addons-production-feed: 27.50.85.8
 * cpanel-plugins: 27.50.85.8
 * base: mirror.ventraip.net.au
 * epel: fedora.melbourneitmirror.net
 * extras: mirror.ventraip.net.au
 * updates: mirror.optus.net
Resolving Dependencies
--> Running transaction check
---> Package wp-cli.noarch 0:1.5.1-2.2.2.cpanel will be updated
---> Package wp-cli.noarch 0:2.1.0-1.el6 will be an update
--> Processing Dependency: php for package: wp-cli-2.1.0-1.el6.noarch
--> Processing Dependency: php-cli for package: wp-cli-2.1.0-1.el6.noarch
--> Processing Dependency: php-common for package: wp-cli-2.1.0-1.el6.noarch
--> Processing Dependency: php-json for package: wp-cli-2.1.0-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: wp-cli-2.1.0-1.el6.noarch (epel)
           Requires: php-common
Error: Package: wp-cli-2.1.0-1.el6.noarch (epel)
           Requires: php
Error: Package: wp-cli-2.1.0-1.el6.noarch (epel)
           Requires: php-cli
Error: Package: wp-cli-2.1.0-1.el6.noarch (epel)
           Requires: php-json
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
and this is the error from WHM when I try and run systemupdate,

Code:
System update process has started.

“yum” reported error code “1” when it ended:  w/ yum -y
Often errors like this can be resolved by running `yum makecache`

System update process has finished.
Any ideas?

thanks heaps,

/end