The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Zen Cart Installation Error

Discussion in 'General Discussion' started by nitram, Oct 13, 2007.

  1. nitram

    nitram Member

    Joined:
    Mar 31, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Hopefully someone can help me with this problem. I can't seem to get anyone to find an answer for this issue, not even at Zen Cart.

    I have installed Zen Cart, both manually & via Fantastico, yet I continue to receive the following code across the top of the cart page:
    Would anyone be able to guide in the right direction to get rid of it, please. The Zen Cart appears to act normally otherwise...
     
  2. nitram

    nitram Member

    Joined:
    Mar 31, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Is there no one willing to comment on this for me, please?
     
  3. rustelekom

    rustelekom Well-Known Member
    PartnerNOC

    Joined:
    Nov 13, 2003
    Messages:
    290
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    moscow
    look as problem is not only zen cart problem. you have problem with session, i don't know anything about your php settings and php version but if you use modern php like 4.4.7 and 5.2.4 you can check is you have set php session.save_path value. it should be set as /tmp
     
  4. nitram

    nitram Member

    Joined:
    Mar 31, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    It is... :)

    Here are my session settings:
    Code:
    session
    Session Support 	enabled
    Registered save handlers 	files user sqlite
    Registered serializer handlers 	php php_binary
    
    Directive	Local Value	Master Value
    session.auto_start	Off	Off
    session.bug_compat_42	On	On
    session.bug_compat_warn	On	On
    session.cache_expire	180	180
    session.cache_limiter	nocache 	nocache 
    session.cookie_domain	no value	no value
    session.cookie_httponly	Off	Off
    session.cookie_lifetime	1	1
    session.cookie_path	/       	/       
    session.cookie_secure	Off	Off
    session.entropy_file	no value	no value
    session.entropy_length	1	1
    session.gc_divisor	100	100
    session.gc_maxlifetime	1440	1440
    session.gc_probability	1	1
    session.hash_bits_per_character	4	4
    session.hash_function	0	0
    session.name	PHPSESSID	PHPSESSID
    session.referer_check	no value	no value
    session.save_handler	files   	files   
    session.save_path	/tmp	/tmp
    session.serialize_handler	php     	php     
    session.use_cookies	On	On
    session.use_only_cookies	Off	Off
    session.use_trans_sid	1	1
     
  5. sarhosting

    sarhosting Well-Known Member

    Joined:
    Oct 1, 2007
    Messages:
    164
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    United States
    cPanel Access Level:
    Root Administrator
    Twitter:
    Could be a couple of things:

    can you provide a php info file:

    <?php
    phpinfo()
    ?>

    In a php info file.
     
  6. nitram

    nitram Member

    Joined:
    Mar 31, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    #6 nitram, Oct 15, 2007
    Last edited: Oct 15, 2007
  7. mattbaros

    mattbaros Registered

    Joined:
    Jun 2, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I had the same problem...

    I had updated my php.ini file using WHM PHP Configuration Editor. It put extra spaces after the file names so instead of "/tmp" it was "/tmp ".

    I edited the php.ini and removed the extra spaces from the save_handler and save_path and it seemed to fix everything.

    Good luck.
     
  8. nitram

    nitram Member

    Joined:
    Mar 31, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    That is what happened. I finally found it when read the PHP.INI file manually, thanks!... :)
     
Loading...

Share This Page