The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Zend 2.1.0

Discussion in 'General Discussion' started by H-T-S, Feb 2, 2003.

  1. H-T-S

    H-T-S Registered

    Joined:
    Feb 2, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I read through the forum that Zend 2.1.0 is compatable with Cpanels php installation.

    Having upgraded Zend twice now, i find the same problem with php functions. It appears that installing Zend 2.1.0 causes a problem with the sockets function within php - The scripts that are installed upon the server that pulll live line feeds in for example cease to work when the new Zend is installed. Downgrading to CPanels bundled version 1.3 solves the issue.

    Certain software requires Zend 2.1.0 (modern bill for one) and we really need to get this to work. Anyone had similar problems, any chance that you can bundle the new version into CPanel nick? or can anyone provide any assistance with this problem?

    Running Redhat 7.3, php 4.2.3 and the latest stable release of CPanel.
     
  2. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    No answers here. We had the same issue with 2.1.0 and php 4.3.0. Rather than drop back a level on php, we dropped back a level on the optimizer. Still haven't found a solution, although I've found other people with the same problem running that combo - just no resolutions.
     
  3. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    I didn't install the lastest apachebuild yet (with php 4.3.0) .

    I'm still on php 4.2.3, does that make a difference at all in combination with Zend 2.1.0 ?
     
  4. H-T-S

    H-T-S Registered

    Joined:
    Feb 2, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Wierd one this, we installed php 4.3.0 + zend 2.1 on another server from the latest buildapache.sea and ran the same scripts that were giving errors with Zend 2.1 and php 4.2.3 and everything seemed to work just fine.

    Have no clues as yet as to why this is.
     
  5. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    [quote:22129d0938][i:22129d0938]Originally posted by thaphantom[/i:22129d0938]

    you HAVE to use php 4.3.0 with Zend 2.1.0[/quote:22129d0938]

    I've installed Zend 2.1.0 with PHP 4.2.3 and everything seems to work fine so far.

    What bugs should I look for, are there some test scripts I can run to see if everything works properly?
     
Loading...

Share This Page