The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

zend core issue?

Discussion in 'General Discussion' started by Zion Ahead, Sep 17, 2007.

  1. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    I'm trying to install Cerberus Helpdesk 4 but I get this error


    Fatal error: Cannot access protected property Zend_Cache_Core::$_backwardCompatibilityArray in /home/user/public_html/cerb4/libs/devblocks/libs/ZendFramework/Zend/Cache/Core.php on line 185


    I have Zend Optimizer 3.2.6 installed now

    Specs:
    cpanel 11 stable
    centos 4.5
    perl 5.8.8
    zend optimizer 3.2.6


    I have this in my php.ini also, maybe something is causing this error??


    disable_functions = show_source, system, shell_exec, passthru, phpinfo, popen, proc_open, readfile, escapeshellarg ,escapeshellcmd, proc_close, ini_alter, dl,popen, show_source, exec


    Thanks for the help.
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Which version of PHP are you using?
     
  3. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    php 4.4.7

    Upgraded zend optimizer to 3.3.0 as well

    Code:
    root@server [~]# php -v
    PHP 5.2.4 (cli) (built: Sep 15 2007 23:28:23) 
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
        with eAccelerator v0.9.5, Copyright (c) 2004-2006 eAccelerator, by eAccelerator
        with the ionCube PHP Loader v3.1.29, Copyright (c) 2002-2007, by ionCube Ltd., and
        with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
        with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologies
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    try commenting out the disable_functions directive in php.ini

    If that doesn't work you'll likely need to take it up with who ever makes that application.
     
  5. katmai

    katmai Well-Known Member

    Joined:
    Mar 13, 2006
    Messages:
    526
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brno, Czech Republic
    sorry to dig but my php5/apache2.0 setup will not load eaccelerator under any circumstances and i have no clue why ...

    www.design-services.us/info.php - phpinfo
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    What's the error you are getting?
     
  7. MaraBlue

    MaraBlue Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    335
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Carmichael, CA
    cPanel Access Level:
    Root Administrator
    To install Cerberus 4 you need to be running PHP5.1+. They also have a very helpful "preinstallation checklist script" (server environment checker) that will tell you what you need to change (if anything) before installing:

    http://wiki.cerberusdemo.com/index.php/Installing_4.0

     
Loading...

Share This Page