cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

Zend Optimizer and Zend Guard Loader are available, depending on the version of PHP you select. Are these the options you are referring to?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

I do not believe Zend Guard Loader is backwards compatible for scripts encoded for use with Zend Optimizer. You can find more information directly from their website:

Zend Guard Loader

Thank you.
 

fulcan1

Member
Aug 5, 2010
5
0
51
Hello :)

I do not believe Zend Guard Loader is backwards compatible for scripts encoded for use with Zend Optimizer.

Hmm I have the same problem and now all scripts from software suppliers that used zend optimiser are now not working. Well that was real smart thinking by ZEND!!! Way to go Zend.
 

Oleg.Gricik

Well-Known Member
Nov 2, 2011
62
0
56
cPanel Access Level
Root Administrator
Hi

There is a way to fix the problem.
You just need to compile separate version of PHP.
One our tech has created a script which can do these.
Such scripts can be found using Google.

After installation of separate PHP (PHP 5.3.10 in our case), you just need to create unique handler in .htaccess file. But make sure, that all scripts under this account require PHP 5.3.x because there are a lot things which are deprecated in this version of PHP(for example maqic_quotes variables).
 

sneader

Well-Known Member
Aug 21, 2003
1,178
57
178
La Crosse, WI
cPanel Access Level
Root Administrator
We are running PHP 5.3. In EasyApache, it offers up this option:

__ Zend Optimizer/Guard Loader for PHP [More Info ↑]
3.3.9 - please read documentation that can found by clicking "More Info" to fully understand this option.


If you look at Zend's website (Download Zend Guard - Zend.com) you will see two options:

Zend Optimizer (Runtime for PHP 5.2 and earlier) --- version 3.3.3
Zend Guard Loader (Runtime for PHP 5.3) --- version 5.5.0


So, EasyApache is a little confusing... I am not sure what 3.3.9 is referring to? And since we have PHP 5.3, it should be installing version 5.5.0 of the Guard Loader.

Thoughts?

- Scott
 

jmarcv

Member
Jan 31, 2004
6
0
151
co
After using easyapache I have this in my php.ini
zend_extension="/usr/local/Zend/lib/Guard-5.5.0/php-5.3.x/ZendGuardLoader.so"
... but php -i says:

PHP 5.3.18 (cli) (built: Oct 29 2012 16:42:04)
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

So what do I have?
 

DomineauX

Well-Known Member
PartnerNOC
Apr 12, 2003
429
11
168
Houston, TX
cPanel Access Level
Root Administrator
The issue of PHP reporting "with Zend Guard Loader v3.3" when the actual version is 5.5.0 (/usr/local/Zend/lib/Guard-5.5.0/php-5.3.x/ZendGuardLoader.so) is causing confusion so could someone confirm why this is reported incorrectly?
I have searched and have not been able to find any explanation for it.