maqsium

Member
Mar 27, 2015
14
0
1
India
cPanel Access Level
Root Administrator
Hi,

I upgraded PHP on WHM server to 5.5.24 and then tried to install opcache from Module Installer, but it was not successful.

I get below error:

Installing PHP Pecl "ZendOpcache"


Code:
pecl/zendopcache requires PHP (version >= 5.2.0, version <= 5.5.0), installed version is 5.5.24
No valid packages found
install failed
The ZendOpcache.so object is not in /usr/local/lib/php/extensions/no-debug-non-zts-20121212
Tidying /usr/local/lib/php.ini...
No changes
Tidying /usr/local/cpanel/3rdparty/php/54/etc/php.ini...
No changes
Any solution to this?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Hello,

You will need to install version 7.0.4 of the Zend OPcache PECL module per https://pecl.php.net/package/ZendOpcache :

Release 7.0.5: PHP Version: PHP version 5.5.0 or older
PHP Version: PHP 5.2.0 or newer
PEAR Package:PEAR1.4.0b1 or newer
Release 7.0.4: PHP Version: PHP 5.2.0 or newer
PEAR Package:PEAR1.4.0b1 or newer
You can do this via the command line:

Code:
pecl install https://pecl.php.net/get/zendopcache-7.0.4.tgz
Internal case number 186893 adds this module as a selectable option in EasyApache. You can monitor the EasyApache change log for this case number to know when it's released:

EasyApache - Change Log

Thank you.