Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

zend-opt and php.ini

Discussion in 'General Discussion' started by WeMasterz5, Oct 29, 2005.

  1. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Miami
    trying to update zend-opt and it keeps telling me it cant because the php.ini can not be written to?


    suggestions
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    did you check the permission and ownership of php.ini ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Miami
    -rw-r--r-- 1 root root
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    Can you paste the exact error message...

    Also check the attribute of that file..
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Miami

    Zend Optimizer installation was NOT completed successfully. │
    │ │
    │ Cannot open file: /usr/local/Zend/etc/php.ini for writing │
    │ │
    │ For further assistance, please contact Zend Support at │
    https://www.zend.com/support/

    0644 on the file
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Are you running the install as root?

    If so, are there any attributes set onyour php.ini:

    lsattr /usr/local/Zend/etc/php.ini

    If so, remove them.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Miami
    this is what that showed

    root@pub1 [/scripts]# lsattr /usr/local/Zend/etc/php.ini
    ----i-------- /usr/local/Zend/etc/php.ini
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    So, you've made the file immutable for some reason which is why you cannot modify it. As I said you need to remove that flag. If you don't know how:

    chattr -i /usr/local/Zend/etc/php.ini
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Miami
    we havent messed with this server in awhile

    that worked.. now hopefully we can fix this darn php issue

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Miami
    Chirpy, if your still around

    would you maybe know why we see this now

    Warning: Illegal offset type in /usr/local/sqmail/src/redirect.php on line 192

    Warning: Illegal offset type in /usr/local/sqmail/src/redirect.php on line 193

    Warning: Illegal offset type in /usr/local/sqmail/src/redirect.php on line 192

    Warning: Illegal offset type in /usr/local/sqmail/src/redirect.php on line 193


    and things like Mambo dont work

    we installed domxml for a site using a yahoo api and things went downhill from there
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice