The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Zend Optimizer 2 cents tip

Discussion in 'General Discussion' started by aljosa, Mar 26, 2007.

  1. aljosa

    aljosa Registered

    Joined:
    Oct 14, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Zend Optimizer 3.2.2 not working with --enable-versioning in PHP 5.2.
    Just update Apache in WHM without --enable-versioning and all starts working just fine.

    :)
     
  2. scriptlisters

    scriptlisters Member

    Joined:
    Mar 9, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    i wish i'd read this earlier!
     
  3. aljosa

    aljosa Registered

    Joined:
    Oct 14, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Better late then never :D
     
  4. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    Old news ... I've known about the versioning conflict with PHP 5 for about 2 years now.

    The problem is not Zend Optimizer but PHP 5 itself with that option enabled.
     
  5. yanayun

    yanayun Member

    Joined:
    May 14, 2005
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    i was try disable versioning, Zend Optimizer not active with php.ini in home folder,
    it's only active without php.ini

    include_path only display .:/usr/lib/php not .:/usr/lib/php:/usr/local/lib/php
    php pear not work with .:/usr/lib/php

    any idea?
     
    #5 yanayun, Aug 18, 2007
    Last edited: Aug 18, 2007
  6. JOHNNY1023

    JOHNNY1023 Registered

    Joined:
    Aug 22, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    May I ask a question?

    HOW COULD I install Zend Optimizer 3.2.2 WITH CPANEL ON MY SERVER?

    BEST,

    JOHNNY
     
  7. rustelekom

    rustelekom Well-Known Member
    PartnerNOC

    Joined:
    Nov 13, 2003
    Messages:
    290
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    moscow
    open /scripts/installzendopt and set required version in begin of file. then save it and run.
     
  8. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Just execute the below script at the prompt:

    /scripts/installzendopt 3.2.2
     
  9. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    That's a known incompatibility with Zend and other modules. The PHP project plans on removing that option in more recent releases.
     
  10. seopro2007

    seopro2007 Registered

    Joined:
    Nov 9, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    How to? I can't find any instructions on this forum.

    Hi,


    can anyone tell me where abouts is this is, I logged into my FTP for my domain and i don't see this path below.

    I have access to a Web Host Manager too and i see no reference to a /scripts/installzendopt or anything referring to how to install zend.

    I downloaded the latest version of Zend and uploaded it to the domain I need to have the files which are encrypted with Zend, but the install didn't work when I ran the install.php file. :(

    Thanks in advance.

     
  11. yapluka

    yapluka Well-Known Member

    Joined:
    Dec 24, 2003
    Messages:
    301
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    France
    cPanel Access Level:
    Root Administrator
    You need root on the server to install Zend - or ask the sysadmin to do it for you :)
     
  12. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    This no longer works any more.
     
  13. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    /scripts/installzendopt 3.3.0


     
  14. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
  15. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Correct. That is due to a change made in build 18033. All branches with that build number (or higher) will only install the most current version of Zend Opt.
     
  16. Domenico

    Domenico Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    362
    Likes Received:
    0
    Trophy Points:
    16
    So isn't this something that must be addressed?
     
  17. Prankerz

    Prankerz Registered

    Joined:
    Dec 30, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    should i just go with /scripts/installzendopt 3.3.0 or is it best (most secure) to go with 3.3.2?
     
Loading...

Share This Page