The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

zend optimizer with 1.3.33 and php 5.1.2

Discussion in 'General Discussion' started by spector, Jan 30, 2006.

  1. spector

    spector Well-Known Member

    Joined:
    Jun 27, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    Did someone managed to run zend optimizer (http://downloads.zend.com/optimizer/2.6.2/) with 1.3.33 and php 5.1.2?

    I wont start (Failed loading /usr/local/Zend/lib/ZendExtensionManager.so: /usr/local/Zend/lib/ZendExtensionManager.so: undefined symbol: zend_extensions) and that is probably incompatibility due to php 5.1.2 and old cpanel apache 1.3.33. Ppl that use apache 2 are not complaining about it.
     
  2. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Compile php without "versioning". Somewhere else on the forums it was pointed out that Zend no longer works with the verioning option.
     
  3. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    The problem seems to be php version 5.1.2 and not the apache version 1.3.33. Downgrade the php version to 4.4.1 and install Zend again. The combination of php 4.4.1 and apache 1.3.34 for Zend installation is working for me.
     
  4. spector

    spector Well-Known Member

    Joined:
    Jun 27, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    this was the issue. Thanks.
     
Loading...

Share This Page