The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

zend optimizer ?

Discussion in 'General Discussion' started by r00t316, Jun 14, 2004.

  1. r00t316

    r00t316 Active Member

    Joined:
    Nov 29, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Not sure what changed on the system.
    Red Hat Enterprise
    apache 1.3.31
    php 4.3.3 and 4.3.7 neither work
    I have 2 other systems identical and zend works fine on those.
    When trying to install it on this system i get the follow.


    -bash-2.05b# php -v
    shmget() failed: No space left on device
    Failed to start up concurrent users module!
    PHP 4.3.3 (cli) (built: Jun 14 2004 03:38:43)
    Copyright (c) 1997-2003 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies
    with Zend Extension Manager v1.0.2, Copyright (c) 2003-2004, by Zend Technologies
    with Zend Optimizer v2.5.2, Copyright (c) 1998-2004, by Zend Technologies
    Segmentation fault (core dumped)

    anyone else have this problem?
     
  2. coastinc

    coastinc Well-Known Member

    Joined:
    Mar 13, 2002
    Messages:
    159
    Likes Received:
    0
    Trophy Points:
    16
    The error that you are getting 'No space left on device' would mean exactly that. Possibly your /tmp partition is full?

    If you'd like us to assist you with this, just drop us an e-mail and we'd be more than glad to.
     
  3. sureshot

    sureshot Member

    Joined:
    Mar 6, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    i've had this same problem happen on one of our servers running RHE3. when Zend is parsing pages sometimes it will give this error, and i've noticed that when running php cron jobs from the command line i will just get a segfault. I had the same setup running on a server with RH 7.3, problem started when we moved some servers to RHE3
     
  4. r00t316

    r00t316 Active Member

    Joined:
    Nov 29, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    /tmp is not full none of the drives are full.
    -bash-2.05b# df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda3 3.0G 246M 2.6G 9% /
    /dev/sda1 198M 52M 137M 28% /boot
    /dev/sda5 3.0G 52M 2.8G 2% /tmp
    /dev/sda6 9.9G 3.7G 5.8G 39% /usr
    /dev/sda7 9.9G 4.1G 5.4G 44% /var
    /dev/sda8 47G 4.5G 40G 11% /backups
    /dev/sdb1 76G 56G 16G 79% /home

    /tmp far from being full.

    This has something to do with zend and this particular system. Kind of odd.

    I have zend running successfully on 3 other RHE3 servers no problems.
    This server in question is has the exact same setup is basically a mirror server of the other servers. Same hardware etc.
    So not sure what the problem is.
     
  5. sureshot

    sureshot Member

    Joined:
    Mar 6, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    what version of php are you running? i saw this thread:
    http://forums.cpanel.net/showthread.php?s=&threadid=24920

    that suggests using version 4.3.5
    i'm recompiling apache and php right now using that version to see if it fixes the prob. i was using php 4.3.7 and zend 2.5.3

    i'll post results after it's done building...
     
  6. sureshot

    sureshot Member

    Joined:
    Mar 6, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    didn't work. same problem.
     
  7. r00t316

    r00t316 Active Member

    Joined:
    Nov 29, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    I tried 4.3.3 and 4.3.7 same problem.
     
Loading...

Share This Page