The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Zend Optimizer...

Discussion in 'General Discussion' started by mitul, Mar 11, 2003.

  1. mitul

    mitul Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Hello All,

    I am using PHP 4.3.1 on redhat linux 7.3 with WHM 6.0.

    I need to install zend optimizer on my server. When I run /scripts/installzendopt the result is

    # ./installzendopt
    Installing Zend Optimizer for PHP 4.2.1,4.2.2,4.2.3
    If this is incorrect please use the correct /scripts/installzentopt-php*
    This requires php 4.2.1
    Press enter to continue or ctrl+c to exit

    How do I install it for php 4.3.1

    Pls. Help

    Thank you,
     
  2. mitul

    mitul Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    I installed it keeping the default php version i.e. 4.2.1 now it logs an error message.

    [Tue Mar 11 08:30:39 2003] [notice] SIGUSR1 received. Doing graceful restart
    Zend Optimizer requires Zend Engine API version 20020429.
    The Zend Engine API version 20021010 which is installed, is newer.
    Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.


    Pls. Help...
     
  3. Johnnie Nelke

    Johnnie Nelke Active Member

    Joined:
    Jan 9, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA
    I just ran the same script on four servers last night and had a HUGE success. When it prompts you to acknowledge yes or no for PHP version 4.3.1 say NO..... then choose 4.3.0 from the next menu. This will cure all your problems. BTW..... it is a very quick process..... had it done in less than 2 minutes per server.
     
  4. mitul

    mitul Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Failed again

    Hello all,
    Thank you for ur replies...

    I just did what u said but Alas!!!!

    When i try to execute the php admin.php from the command line it says Now

    "Zend Optimizer requires Zend Engine API version 20020429.
    The Zend Engine API version 20021010 which is installed, is newer.
    Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer. "

    I think i'll downgrade to php 4.3.0 that will be the solution is it?

    and one more It didn't ask me for any version info of php as u said.

    When i say ./installzendopt it says the version message and enter to continue, when i press enter it installs and then when i restart apache it gets restarted but my error_log gives me the same notice.

    Regards,
     
  5. Johnnie Nelke

    Johnnie Nelke Active Member

    Joined:
    Jan 9, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA
    you need to run it as
    /scripts/installzendopt

    you will go through a few various screens.... then it will ask you to confirm php version 4.3.1.... lie to it and say NO... then you will have the option to select which version of PHP you have..... choose 4.3.0..... .1 only has a couple of patches and works fine with zend 2.1.
    If you had to start it all over would not take more than 10 minutes or less..... using
    /scripts/easyapache first..... choose option 4.

    then run /scripts/installzendopt and follow the above guidelines...... just pay attention to the screens and look for the php version verification..... make sure you choose 4.3.0 and everything will be fine. I have 4 servers so far and not one client on any of them have had an error since we updated everything.

    I found the same information I am passing on to you in this forum.... and I was amazed at how easy it was. ;)
     
  6. mitul

    mitul Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Thanks It Worked

    Hello,

    Thank You Very much...

    Actually It was my mistake i was running the older version of installzendopt.

    I updated the Backend Scripts from WHM and it gave me a new script with renaming the older one to installzend.old. Then i executed the new installzendopt and followed the instructions and used the false the php verison and it Worked.

    Thank You again.

    Regards,
     
Loading...

Share This Page