The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ZLib version

Discussion in 'General Discussion' started by Hoojx, Mar 1, 2004.

  1. Hoojx

    Hoojx Active Member

    Joined:
    Jun 5, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    6
    phpinfo() shows that

    zlib
    ZLib Support enabled
    Compiled Version 1.0.8
    Linked Version 1.0.8

    I've zlib 1.1.4 installed on the server. I've tried to upgrade apache etc. but it is still 1.0.8

    Can someone tell me how to update it ?

    THanks.
     
  2. BrightAdmin

    BrightAdmin Well-Known Member

    Joined:
    Feb 29, 2004
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Hi Hoojx,

    Please recompile apache with zlib by adding '--with-zlib' option along with other options to display a updated version of it in phpinfo.

    ./configure --with-zlib

    Regards,
     
  3. Hoojx

    Hoojx Active Member

    Joined:
    Jun 5, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    Thanks for your reply.

    I've tried that out but it is still pointing to the old 1.0.8 version. Any idea ?
     
  4. BrightAdmin

    BrightAdmin Well-Known Member

    Joined:
    Feb 29, 2004
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    Please try running these scripts. hope this will help you
    /scripts/updatephpconf
    /scripts/phpini

    And finally restart the apache using:

    /etc/rc.d/init.d/httpd stop
    /etc/rc.d/init.d/httpd start

    Regards

    :)
     
Loading...

Share This Page